BGP实验

BGP实验

  1. EBGP实验

1.1 拓扑图


1.2 配置

1) R1配置

R1>en

R1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R1(config)#int g0/0

R1(config-if)#ip add 10.0.0.2 255.0.0.0

R1(config-if)#no shut

R1(config-if)#int g0/1

R1(config-if)#ip add 20.0.0.2 255.0.0.0

R1(config-if)#no shut

R1(config-if)#exit

R1(config)#router bgp 200

R1(config-router)#neighbor 10.0.0.1 remote-as 100

R1(config-router)#neighbor 20.0.0.1 remote-as 300

R1(config-router)#%BGP-5-ADJCHANGE: neighbor 10.0.0.1 Up

%BGP-5-ADJCHANGE: neighbor 20.0.0.1 Up

 

2) R2配置

R2>en

R2#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R2(config-if)#interface g0/0

R2(config-if)#ip add 10.0.0.1 255.0.0.0

R2(config-if)#no shut

R2(config-if)#

R2(config-if)#exit

R2(config)#router bgp 100

R2(config-router)#neighbor 10.0.0.2 remote-as 200

R2(config-router)#%BGP-5-ADJCHANGE: neighbor 10.0.0.2 Up

R2(config-router)#network 10.0.0.0 mask 255.0.0.0

R2(config-router)#

 

3) R3配置

R3>en

R3#conf terminal

Enter configuration commands, one per line. End with CNTL/Z.

R3(config)#interface g0/0

R3(config-if)#ip add 20.0.0.1 255.0.0.0

R3(config-if)#no shut

R3(config-if)#exit

R3(config)#router bgp 300

R3(config-router)#neighbor 20.0.0.2 remote-as 200

R3(config-router)#%BGP-5-ADJCHANGE: neighbor 20.0.0.2 Up

R3(config-router)#network 20.0.0.0 mask 255.0.0.0

R3(config-router)#

1.3 结果

R2 ping R3

R3 ping R2

R1的路由表

R2的路由表

R3的路由表

2 含IBGP实验

2.1 拓扑图

2.2 配置

1) R5

R5#conf t

R5(config)#int f0/0

R5(config-if)#ip add 10.0.0.1 255.0.0.0

R5(config-if)#no shut

R5(config-if)#exit

R5(config)#router bgp 100

R5(config-router)#neighbor 10.0.0.2 remote-as 100

R5(config-router)#network 10.0.0.0 mask 255.0.0.0

R5(config-router)#

 

2) R6

R6(config)#int f0/0

R6(config-if)#ip add 10.0.0.2 255.0.0.0

R6(config-if)#no shut

R6(config-if)#int f0/1

R6(config-if)#ip add 20.0.0.2 255.0.0.0

R6(config-if)#no shut

R6(config-if)#exit

R6(config)#router bgp 100

R6(config-router)#neighbor 10.0.0.1 remote-as 100

R6(config-router)#neighbor 10.0.0.1 next-hop-self

R6(config-router)#neighbor 20.0.0.1 remote-as 200

R6(config-router)#

 

3) R7

R7#

R7#conf t

R7(config)#int f0/0

R7(config-if)#ip add 20.0.0.1 255.0.0.0

R7(config-if)#no shut

R7(config-if)#exit

R7(config)#router bgp 200

R7(config-router)#neighbor 20.0.0.2 remote-as 100

R7(config-router)#network 20.0.0.0 mask 255.0.0.0

R7(config-router)#

2.3 结果

R5 ping R7

R7 ping R5

R5路由表

R6路由表

R7路由表